I am trying to start pset7 but whenever I try to use phpMyAdmin I get this error:

You don't have permission to access /phpMyAdmin on this server

In my experience, I should get a popup asking for a username and password, but I don't get that. How do I fix this error?

  • What version of the CS50 Appliance are you running? And have you tried running update50? Jun 9, 2014 at 5:59
  • @malan I am running version 19 (Or the version which was released for this 2014 course) and I did try running update50
    – lijrobert
    Jun 9, 2014 at 12:09

3 Answers 3


Just to back up a step. You are able to access http://pset7 okay? But http://pset7/phpMyAdmin gives you a forbidden? Did you chmod all the files as outlined in the pset instructions in the Getting Started section?

  • I just made sure I went through all the steps and it is still not working. Thanks though
    – lijrobert
    Jun 9, 2014 at 11:48
  • I have the same problem: pset7/login.php loads just fine, whereas pset7/phpMyAdmin gives me a 404 error. I've double-checked everything, and the appliance is updated. Dec 15, 2014 at 15:55
  • For some reason, running localhost/phpmyadmin instead worked! Dec 15, 2014 at 16:15
  • i am having a similar issue Using Localhost won't help because msql is not running I need instructions for getting mysql running on this appliance.
    – yorroy
    May 19, 2015 at 19:31
  • i am having a similar issue. Using localhost won't help because mysql is not running. I need instructions for getting mysql running on this appliance. Or is it the case that mysql is running on a server somewhere else?
    – yorroy
    May 19, 2015 at 21:08

First thing first.

From what you said, I assume you are trying to access phpMyAdmin from inside yur appliance.

As a rule of thumb, ALWAYS run update50 when you start your appliance.

If you get the "Forbidden" error when you load phpMyAdmin, remember you should log in as jharvard/Crimson

If you get the "Forbidden" error when you load a table in phpMyAdmin, odds are you are trying to drop a table on which you don't have permissions.

If you get the "Forbidden" error when you load a php page that uses the database, yo did not modify the attributes of the php page: go to ~/vhosts/pset7 and execute the command chmod a+x on the required files as per the specifications.


  • My problem is that I am not getting the login prompt for phpMyAdmin at all. It's not like I'm getting it and then typing in the wrong thing. Thanks though @Cygni_61
    – lijrobert
    Jun 9, 2014 at 11:28
  • Did you try using Chrome? What page do you reach when inserting the link pset7/phpmysqladmin?
    – Cygni_61
    Jun 9, 2014 at 11:45
  • I did use chrom and with pset7/phpmysqladmin, I get a not found error. Let me resay this: The site works. I get the login page. I just can't get to phpMyAdmin
    – lijrobert
    Jun 9, 2014 at 11:48
  • I see what you mean. That happened to me also, when I was working on the answer. I get an "Ooops... can't find your page" error from Chrome, so I guess it's a sort of server-side error.
    – Cygni_61
    Jun 9, 2014 at 11:53

In case others encounter this problem, I rebooted my virtual machine (the appliance instance, not just fusion. That restarted mysql. That was the only approach I could find.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .