I recently finished my code for pset5 recover.c. It compiles, and runs successfully and recovers all 50 pictures. But when I try check50, it gives

Checking............................................................................................................................ Unexpected end of input

Any ideas what's going wrong?

PS: I've tried updating the app, turning if off and on again, checking net connectivity, and successfully tested it with Valgrind and GDB and nothing seems to be out of order.

1 Answer 1


The issue you are facing has been somewhat common lately.

I watched a video where Prof. Malan talks about how the cloud framework was implemented. He explained that, as resources are limited, some slowdown can appear when many students work together on highly intensive tasks.

Now, Pset5 and Pset6 are the most intensive problem sets, the first is I/O bound, the second is CPU bound.

As the schools close during summer, there have been many more students asking for resources, and the back-end servers slowed down a little. This means that more time was required to complete each single task.

Unfortunately, each task that runs on the server is scheduled a maximum slice of time to be executed for efficience purposes. When the time slice is completed, the application is shut down, and the checking routine faces an unexpected ed of input. For this reason, we may have correct programs that don't always pass the check50 routine.

My hint is: start the next Pset while trying check50 on Pset5, possibly on non-peak hours: your program will pass it with flying colours.

  • I can concur with this - I was getting really frustrated with check50 and pset5, but eventually it passed without any errors and without me modifying my code at all. Maybe a little more comms from the otherwise awesome faculty would be nice, would help reassure and stop us thinking we've gone mad! Jun 9, 2014 at 20:25
  • I agree!! I had my recover program working and passing all check50 tests, then I went back to add some comments to help with readability, then ran it through check50 again just to make sure I hadn't accidentally broken something. When I got the "expected end of input" message I panicked. Glad I found this thread, and thanks for the answer Luigi! I waited a few minutes and tried again and it passed all checks again. Aug 22, 2014 at 21:29
  • Happened to me on pset3, then I looked here and waited a few minutes, now it's fine.
    – jhschwartz
    Mar 28, 2015 at 14:32
  • It must be bad right now - I can't even check Mario in pset1!
    – cyberspy
    Jun 13, 2016 at 19:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .