I am not able to login to CS50.net, and cannot submit a pset. I signed in and enrolled using the google-signin-option.

I saw one user who had this problem as well. Are there others here signed in via Google? Is creating an all new account on EDX really the only option? I'd hate to do that because that would mean I have to set up another email account just for it.

  • Can you provide more details? Have you tried resetting your password?
    – i_am_david
    Commented Jul 24, 2015 at 20:33
  • I actuallly registered with EDX by clicking the 'Create an account using Google' option. Now, as long as I am logged in to Google in my browser, I can sign in to EDX by clicking on the 'sign in with Google' button without any need to specify a pasword. It's only when clicking the 'CS50 submit' link that I am asked to provide my credentials. I can browse all CS50 course info on the EDX site. Resetting the password would be resetting my google password... I can't really see how that could help. I contacted EDX with this poblem. Commented Jul 24, 2015 at 20:57
  • You should be opening CS50 submit inside the appliance... So it makes sense that you need to log in again.
    – i_am_david
    Commented Jul 24, 2015 at 21:05
  • I installed VirtualBox, downloaded the appliance, and tried to log in there. Had the same result. Commented Jul 25, 2015 at 5:24

1 Answer 1


When you registered for edx with your Google account, you must have specified a password. The form requires it. Use that password and your username, and it should work. If you forgot your username, it is the top right corner of any edx page you are logged in to. If you forgot your password, click the small down arrow beside your username in the top right corner, and click account settings. Scroll down, and there is a button to reset your password.

  • Tried it out immediately, and sure enough: I am logged in! Thanks so much for your answer. Commented Jul 25, 2015 at 5:34
  • BOOM :) You're welcome!
    – i_am_david
    Commented Jul 25, 2015 at 5:47
  • The form actually does not require a password if you sign in with Google. That is the underlying cause of this issue. The solution is to reset your edX password (even though you never had one) and then use that new password.
    – curiouskiwi
    Commented Jul 25, 2015 at 7:52
  • @curiouskiwi I tried making an edX account by registering with Google, and pretty much it takes a bunch of your Google profile info and plugs it into the normal registering form. You still need a password.
    – i_am_david
    Commented Jul 25, 2015 at 15:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .