1

I am having issue on using spl library in ubuntu. When I try to compile window.c using make as given in the instructions I am always getting the same error(in pic) even though the spl/include folder containing all the header files and spl/lib is in the same directory as in the screenshot.

I have referred to the following link which was similar to the issue that I am facing but had no success : How to install SPL libraries in ubuntu?

screenshot of error on compiling window.c

Could anyone guide me on solving this problem

Thanks

  • I had the same error with my Ubuntu 14.04.2 i just moved /spl directory to /usr/local/include/ & /spl/lib/libcs.a to /usr/local/lib/ & edited Makefile and removed -Ispl/include & -Lspl/lib flags – saimischief Jul 29 '15 at 16:37
  • @ekkasai - I Tried your way but still it's giving me the incompatible error. Thanks for your suggestion anyways, it was something that i hadn't read in any of the previous posts. Might help someone else. Thanks. – kunal Aug 2 '15 at 3:54
  • in c code we include like #include <spl/gwindow.h> it means all your header files should be under /spl directory by default it is in /spl/include/ directory to recheck if header files are in correct directory enter ls /usr/local/include/spl/*.h in your terminal – saimischief Aug 2 '15 at 4:13
  • @ekkasai - Yeah i had checked and the files are in the correct places but I think the issue is that the library object code libcs.a is incompatible with my 64 bit ubuntu – kunal Aug 3 '15 at 15:21

You must log in to answer this question.

Browse other questions tagged .