1

Hey guys hoping to get some help with a tricky issue here. Do to certain circumstances I had to take a break from cs50 in the middle of pset8. It’s been about 3 weeks now and I’m just getting back to the problem set. I left off at the addMarker function in scripts.js. Before taking a ‘leave of absence’ the Mashup was working well. All steps had been completed up until this point. Now, I’m trying to view http://pset8/ in Chrome on the appliance.

What I was met with was a white screen with no map and only the search bar. Immediately I’m thinking permissions. I adjust accordingly, no file seems to be sticking out, but chmod just to be safe. Refresh the page and still i’m met with white screen, no map, just search bar. I opened up the JS console in chrome and there are 3 errors: Failed to load resource: https://maps.googleapis.com/maps/api/js net:: ERR_INSECURE_RESPONSE , Uncaught ReferenceError: google is not defined pset8/:1 , and Uncaught ReferenceError: google is not defined scripts.js: 17.

I haven’t made any changes to any files, the permissions seem to be right, line 17 of scripts.js is the same as it comes in the distribution code. Any ideas? looking up ERR_INSECURE_RESPONSE as im writing this.

7

if anyone has run into the issues i have stated above there is a simple fix. Doing some searching around and trying to access urls using https showed me my appliance was not ‘secure’. By going into settings and manually changing the time and date of the appliance, everything is right back on track

| improve this answer | |
  • You can also accept your answer as correct to help others. – ChrisG Aug 2 '15 at 21:29
  • @ChrisGantidis not the for the next 24 hours – jakewies Aug 3 '15 at 22:59
  • I am having the same problem with my map not loading with just a text box appearing. Can someone please explain how I can access and change the date and time in my appliance? I have tried clearing my cache, using F5 to reload the page but nothing is working for me. Can someone please help me out? – Mark Edwards Nov 29 '16 at 5:38
3

USE A DIFFERENT BROWSER. I tried using Mozilla instead of chrome to load the page, and it worked wonders for me!

| improve this answer | |
2

I also had this issue. The Date/Time adjustment didn't help but an Update50 and a reboot sorted it for me.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .