0

I am using a macbook (in the UK) to run the CS50 Appliance, and am struggling to find all the characters that I need. I have discovered the following:

(hash) # = Shift + 3

(tilde) ~ = Shift + the +- symbol in the top left corner

Also, the @ key and " key are switched around - similar to a UK windows keyboard.

However, I can't find a \ (backslash) anywhere! Has anyone else using a mac had these same problems?

2
  • Have you made sure that your VMWare settings are set to the correct keyboard? I'd try that first.
    – curiouskiwi
    Aug 3 '15 at 0:35
  • Thanks curiouskiwi. I have managed to find the settings in the preferences now. Much easier!
    – Gemma Down
    Aug 3 '15 at 0:35
2

As curiouskiwi helpfully said, you can change the keyboard settings in VMWare by clicking on 'VMWare Fusion' in the app, then 'Preferences', 'Keyboard and Mouse'. Then click on the drop down box, and choose "Edit Profiles". Click on 'Mac Profile' then the little cog icon and choose 'Make Default Profile'.

This then allows you to use the mac keyboard as normal whilst in the terminal.

Thought I'd add this in case anyone else had the same problem!

1
  • You got it. In 2 days time, can you come back and "accept" your answer as the correct one? That'll take it off the unanswered queue. :)
    – curiouskiwi
    Aug 3 '15 at 1:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .