0

When I compile this for pset4

#include "gevents.h"
#include "gobjects.h"
#include "gwindow.h"

int main(void)
{
        // do something
}

I get this error

jharvard@appliance (~): clang -ggdb3 -Ispl/include -O0 -std=c99 -o move move.c -Lspl/lib -lcs -lm 
move.c:1:10: fatal error: 'gevents.h' file not found
‪#‎include‬ "gevents.h"
^
1 error generated.
3

The required header files are included in both the pset4.zip and the src5m.zip. Bounce is part of the latter though, so I would say to just run unzip src5m.zip in your Dropbox folder again, and watch for any errors on unzip. upon successful unzip, the gevents.h file will be in ~/Dropbox/src5m/spl/include folder

| improve this answer | |
  • I tried this and opening and closing the appliance I still get the same error message. This is about the tenth technical error I have experienced so far in this course. – user1703 Jul 30 '14 at 6:35
  • Could a TA/TF please assist. There are a number of things online students cannot resolve themselves. I have searched this blog, Google, Stack overflow and cannot resolve this matter. I am unable to move forward because of this minor issue, on which I have spent several days, which time I cannot afford. If I am unable to solve this in the next day, I will have to consider dropping out. – user1703 Aug 2 '14 at 6:25
  • I still have this error and I am in Cs50X. And I need this for my final project! – Richard Qiu Dec 23 '14 at 4:43
0

i had this happen once. i closed the appliance and opened it again, which apparently fixed it.

| improve this answer | |
-1

I had the same problem, and update50 fixed it.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .