0

I really need help with updating the cs50 appliance. I resently upgraded to windows 10, and then i couldnt get the cs50 appliance to work so i reinstaled windows 7. After this i haven't been able to update the cs50 appliance. Everytime i try to do it i get this error ( its very long) I hope its ok if i copy and past it here. if someone has an answer that would be great or if someone could point me in the direction of finding an answer would also be great.

I realise this might be something to do with the hyperviser but i'm posting here since people are always very helpful. also im using virtualbox.

Error

The GRUB boot loader was previously installed to a disk that is no        
 │ longer present, or whose unique identifier has changed for some           
 │ reason. It is important to make sure that the installed GRUB core         
 │ image stays in sync with GRUB modules and grub.cfg. Please check          
 │ again to make sure that GRUB is written to the appropriate boot           
 │ devices.                                                                  
 │                                                                           
 │ If you're unsure which drive is designated as boot drive by your          
 │ BIOS, it is often a good idea to install GRUB to all of them.             
 │                                                                           
 │ Note: it is possible to install GRUB to partition boot records as         
 │ well, and some appropriate partitions are offered here. However, this     
 │ forces GRUB to use the blocklist mechanism, which makes it less 

I couldn't seem to get it to go full screen, however i have had it full screen just hours ago! and it looks the same simply spread out more. enter image description here

13
  • Did you have an external drive or a USB drive connected the first time you installed the appliance?
    – ChrisG
    Aug 9 '15 at 19:59
  • No i dont, I had the same hardware now as i did before i instaled windows 7. The update50 command worked fine back then.
    – Jay Jay
    Aug 9 '15 at 20:02
  • No I mean after you installed Windows 7, and then installed VirtualBox/VMWare, and the you imported the appliance. When you imported it did you have anything else connected?
    – ChrisG
    Aug 9 '15 at 20:16
  • I didn't. I have only one internal HD and its the only thing connected. I have tried to reinstal virtual box and the cs50 but to no avail.
    – Jay Jay
    Aug 9 '15 at 20:32
  • Don't you get a list of devices after the error? Something like this? GRUB install devices: [ ] /dev/sda (3000592 MB; ST3000DM001-9YN166)
    – ChrisG
    Aug 9 '15 at 21:02
1

After The update failed for me (the error about GRUB), i couldn't attempt any other command at the terminal. So i removed the CS50 appliance and then imported it again for a fresh start with original settings, files ect. This time instead of running 'update50' in the terminal i first ran 'sudo grub-install /dev/sda'. And then when it completed i rebooted the appliance and then ran 'update50' in the terminal window.

Eventually the update got to the GRUB error i had seen before. This time i was able to simply press enter and choose a place to install the GRUB software, I installed it onto the disc imagine created when i imported the cs50 appliance.

Then that was it, Smooth sailing from there on to the end of the update!

Thanks a lot to ChrisG who helped a heap loads to figure this out.

1
  • Good job. Hope my comments helped.
    – ChrisG
    Aug 10 '15 at 9:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .