0

I need some help! I've just installed the CS50 Appliance 2014, but I'm Italian and I'm using a Macbook Pro, so everything on the keyboard is different. I've tried to switch to "Italian", "Italian (Macintosh)", and also change the model from Generic to Macbook Pro in Settings->Keyboard->Layout, but it's not my layout. How can I solve this problem?

7
  • Maybe take a look at this? If it doesn't work I think @Cygni_61 will know how.
    – ChrisG
    Aug 12 '15 at 6:33
  • In the end I kind of solved it adding in "Preferences" of VMware Fusion Mac Profile as default, and Italian as language, only one little problem is that "<" and ">" are reversed with "\" and "|". It's not a big problem of course, but if someone knows how to solve it it would make things a little easier :) Thanks anyway! Aug 12 '15 at 11:02
  • Try this in a terminal and let me know xmodmap -e 'keycode 94=masculine ordfeminine backslash brokenbar backslash brokenbar' -e 'keycode 49=less greater' (taken from cs50.stackexchange.com/questions/7783/spanish-keyboard-layout)
    – ChrisG
    Aug 12 '15 at 11:06
  • This partially worked, because now < and > are in their correct places but "\" and "|" disappeared. I would have preferred the last settings where at least I could use every letter and symbol. How can I solve this? Aug 12 '15 at 15:22
  • Hi, I solved the problem modifying the code changing the part of keycode 94, here's the modified code: xmodmap -e 'keycode 94=backslash bar' -e 'keycode 49=less greater' thanks for the help! Aug 12 '15 at 15:34
1

We solved it setting in "Preferences" of VMware Fusion Mac Profile as default, and Italian as language in the Appliance, and modifying a code (taken from here) for putting <>\| in the right place. here's the modified code:

    xmodmap -e 'keycode 94=backslash bar' -e 'keycode 49=less greater'

Thanks to @ChrisG for the help!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .