i can't run the staff implementation for any problem set, i always get the same error, it's always something like : bash: ~cs50/pset4/breakout: No such file or directory

  • I’m having the same problem for the cs50 2014 fall appliance. I did all the things curiouskiwi suggested, substituting 2014 for 2013 where necessary. The terminal said, rpmquery is not currently installed. Please ask your administrator to install the package rpm. Any advice would be appreciated! Thanks!
    – kames
    Feb 4, 2015 at 7:40

3 Answers 3


You should be in ~/Dropbox/pset4 directory.Then execute command ~cs50/pset4/breakout.

  • This is for staff solution :) This is given in PSet4 specifications.
    – Paurush
    Jun 19, 2014 at 15:44
  • I'm sorry! Didn't read your answer carefully! Though this is just the path for the staff's solution!
    – kzidane
    Jun 19, 2014 at 16:20
  • No probs bro :)
    – Paurush
    Jun 19, 2014 at 16:25
  • This does not seem to work. To the staff: What not put all staff implementations in one place, e.g., link to them on the <courses.edx.org/courses/HarvardX/CS50x3/2015/info>?
    – KimPhilby
    Aug 11, 2015 at 14:54

To run the staff's solution for pset4 - breakout, run the following commands:

cd ~cs50/pset4
  • The breakout executable was there yesterday, but not today. This is what is there: harvard@appliance (/home/cs50/pset4): ls resize
    – rl777
    Oct 17, 2014 at 20:34

If you are running ~cs50/pset4/breakout and you get a bash error, that may indicate that your appliance is not up to date.

First, please run update50 and then version50. Does it show version 19-2? If so, try running ~cs50/pset4/breakout again.

If your version doesn't show 19-2, you may have installed an older version of the appliance and you will need to re-install with the latest version (version 19).

If your appliance is up to date but the staff version still doesn't work, please run:

rpmquery cs50-2013-fall

What does it report? If you see "package cs50-2013-fall is not installed", then please run this:

sudo yum -y --disablerepo=* --enablerepo=appliance50 install

That should make sure the staff versions are installed.

Hope that helps, Brenda.

  • thanks a lot for ur help, i found out that the staff version is not installed, but when i execute: sudo yum -y --disablerepo=* --enablerepo=appliance50 install ... it didn't install anything and i still get the same error
    – user1383
    Jun 21, 2014 at 6:47
  • And you're definitely running version 19-2? I'm not quite sure what you will need to do if that install didn't help.
    – curiouskiwi
    Jun 21, 2014 at 6:49
  • the command "version50" didn't work, but i updated my appliance and in the bottom right corner it is written 19-2 so i think i used the correct version
    – user1383
    Jun 22, 2014 at 6:01
  • You should define the package to be installed in the end of the command, after "install". So the complete command should be: sudo yum -y --disablerepo=* --enablerepo=appliance50 install cs50-2013-fall
    – user2603
    Sep 26, 2014 at 3:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .