2

Do any of my fellow students have the appliance up and running on a Linux box? If you do please let me know what Linux distribution you are running, which installation instructions you followed that worked for you, and any other pertinent details about your setup (hardware, configuration, etc.)

I have been trying for a week to install Appliance 19 for doing the problem sets in CS50x.

First, on this page, the following link:

If you have a PC running Linux, we recommend that you follow these instructions for VMware Player

takes you to a page that says its for Windows rather than Linux at the top. I think the instructions there must be the same for Windows or Linux and perhaps the author simply copy/pasted the Windows instructions but forgot to update the page to say "Linux" at the top. But it should say Linux at the top if you clicked on Linux. Anyway, I followed those instructions and installed VMware using sudo bash filename but it won't import the appliance file once its installed. It either crashes (disappears) or throws various errors.

I've tried on several different Lenovo I5 Thinkpads with plenty of RAM. I have freshly installed & updated different Linux distributions (Linux Mint, Ubuntu, Lubuntu, LXLE) to try to solve the problems as well.

The alternate instructions for using VirtualBox instead if you have trouble with VMware gave me an appliance that loads but without functional network capability. So I can't get anything in or out of that appliance to interact with the class. I tried all the various adapter settings with the same result but no luck. Also tried reinitializing the MAC addresses of the adapters which is not specified by the instructions but I thought was worth a try, but no luck.

Can someone please help get me going so I can follow along with the class? If we can't get the Appliance installed, is it possible to get the problem set material in a different form and simply code it on my local machine and then submit to the course site as I have done for many other online courses in the past?

2

I am using the Appliance on Ubuntu 14.04. Initially I tried VMware and ran through lots of trouble, but then I used VirtualBox (which I had previously installed,) and everything worked fine.

After removing VMware (with VirtualBox installed,) I just double clicked the Appliance's OVA file, and it got installed. At the end of the VirtualBox tutorial for Linux on the Appliance site, there is Troubleshooting section which I had to follow to get the network working.

All the best,

Khalid

| improve this answer | |
  • Khalid, Thanks so much! I was able to get a little further in using your comments above. The trick was to simply double-click on the OVA file rather than opening that file from VirtualBox as the manual instructs us to do. Now its running and I have reached the Harvard CS50 Register page. Am I supposed to put my info here or JHarvard's info? – user1385 Jun 19 '14 at 20:51
  • I am glad this worked. You should enter your information for the CS50 team. – baloushi Jun 19 '14 at 21:01
  • Thanks, well I spoke too soon. I entered my info and then tried to shut down and restart the appliance (saving state info) and when I started the appliance again I was back to no internet connection. Darn! – user1385 Jun 19 '14 at 21:16
  • OK, back in now. I guess I should not shut it down!!! – user1385 Jun 19 '14 at 21:23
  • Just try the troubleshooting section to ensure that the network is set properly. I hope this works. – baloushi Jun 19 '14 at 21:26
0

Just a suggestion, but when everything in VirtualBox is working well, take a snapshot (steps: Machine, Take snapshot) so that you can revert to the saved state if you need to. Also, when you close out of a session when everything is working well, save the machine state so that it will start up with everything the way you left it.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .