With pset7 you were instructed on setting up a private website that could only be viewed in the applience it self.

I would like to this again i tried this for pset8 i do know i should should deploy that problemset under the public folder since there isn't a google earth plugin for google crome just yet.

But still it kinda bother me i haven't been able to figure out what is wrong. I did chmodded the folders and files but i still get a 404 when i open pset8 from the browser :(

cd ~/vhosts/pset8 find . -type f | xargs chmod 644 find . -type d | xargs chmod 711 chmod 711 ~ chmod 711 ~/vhosts

Permissions settings in image below: enter image description here

  • I see that you have the files in place, you have redirected pset8 to correctly, but I don't see the actual server running. Could you make a screenshot of that too?
    – skreborn
    Jun 21 '14 at 17:33
  • you would get a 204 no content error if the status is not running. Anyhoo httpd starts on boot s30.postimg.org/xl6l99lo1/rights_2.jpg
    – user1419
    Jun 22 '14 at 17:35

I'm afraid you decompressed your pset8 zipfile in the wrong folder: I have mine in the localhost directory, as in

jharvard@appliance (~/vhosts/localhost/public/pset8): ll
total 24
drwx--x--x. 2 jharvard students 4096 Apr 26 12:12 css
drwx--x--x. 2 jharvard students 4096 Nov  8  2013 fonts
drwx--x--x. 2 jharvard students 4096 Nov  8  2013 img
-rw-r--r--. 1 jharvard students 5632 Apr 26 12:19 index.html
drwx--x--x. 2 jharvard students 4096 Apr 26 13:59 js

In fact, your "public" folder (the one reached by your browser) should be inside the localhost, while the directory you point to using the browser, /pset8, is inside the public folder.

  • i'm trying to set up pset8 as pset7 is setup by decompressing the file under ~/vhost itself
    – user1419
    Jun 30 '14 at 16:57
  • You can still crete a folder named "public" and copy everything inside it...
    – Cygni_61
    Jul 10 '14 at 14:17
  • I have the same problem, pset instructions say to unzip in /vhosts and not /vhosts/localhost?? presumably that is why we are then asked to amend /etc/hosts with the ip address and pset 8 and not, as with pset7 with the ip address and localhost/pset7. Dec 16 '15 at 12:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .