I'm having a problem with VMware and the CS50 appliance.

I don't have anything fancy, like Fusion - just VMware Player 6.0.1 build-1379776. My computer runs Windows 7 Home Premium.

The player itself works fine but when I open the appliance file it shows the message, "Error while powering on: Internal error" as shown in the image below. How can I fix this error?

VMware Player Failure

  • I don't use VMware Player anymore, but when I was using it, I got this very same error and I simply restarted my PC to fix it. I honestly didn't search for any other solutions, so there might be one out there other than restarting your PC, but until you find it, you may try restarting your PC and try again! – Kareem Jun 23 '14 at 10:42
  • If @Kareem's suggestion works for you, please let us know/answer the question with that solution. – Air Jun 23 '14 at 16:33
  • I answered already... Deleted it though. Kind of annoying. Anyway, @Kareem's solution worked! Thanks for helping! – ChiCubed Jul 2 '14 at 11:13
  • I'm having the same problem! I have already restarted my laptop twice, but it's not working anyway. Does anyone know any further method to fix this? – user2284 Aug 25 '14 at 20:57
up vote 7 down vote accepted

I started the VMware Player in Administrator Mode and it worked.

  • Helps in my case with Suse vmaware – olly Nov 15 '14 at 7:58
  • same for me. Actually, i did it twice and solved the problem. – user3100 Nov 25 '14 at 18:45

I restarted my computer and it worked!

  • I am now having the exact same problem. The appliance ran fine yesterday, but continues to give me an Internal Error every time I've tried today, even after rebooting my computer. If anyone has any other ideas on how to solve this, advice would be appreciated. – Starshadow Jul 1 '14 at 23:23
  • Starshadow, I tried again the next day. It didn't work, even after rebooting the computer. Maybe leave off for a couple of hours, then try again? – ChiCubed Jul 7 '14 at 4:06
  • I actually ended up having to to a repair on the VMware Player - I've had to do it twice now. So you may need to do that (and keep the download file because it may be necessary to do it often until you get finished with the course). Very frustrating. – Starshadow Jul 7 '14 at 15:19
  • @Starshadow Can you post the details of how to "do a repair on the VMware Player" as a separate answer? That way it is easier for people to find, and they can vote it up if it works for them. – Air Sep 12 '14 at 23:15
  • @Starshadow: Could you please tell how to do a repair. I find VMWare to be brittle and crashes routinely, and I find no tools for recovery or repair! – Jonathan Wood Mar 5 '15 at 0:31

You can follow:

Start -> Services.msc -> VMWare Authorization -> Click Start

  • This assumes it's not already running--a bad assumption. And restarting doesn't help me either. – Jonathan Wood Mar 5 '15 at 0:29

Starting up the Vmware application in administrator mode solves the problem . So try exiting and start it up in administrator mode

I have the same error; I installed and executed in Administrator mode, also Services.msc--> VMware Authorization Service is in Start postion...

I did installed VMware Player 12.0.0 exe in Windows 10 Pro.

But nothing was solved yet? Anyone help me to solve it ASAP? Thank you.

  • 1
    This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – ChrisG Aug 23 at 13:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .