0

enter image description here

I can't access anything in my table due to this error. I have read several solutions before I ask this question and I did try them but nothing worked out so please can you tell me another procedure which I can follow to solve this problem, I'm stuck! I previously tried " sudo dpkg-reconfigure phpmyadmin -f noninteractive" and then restarting the apache2 server.

1

I had this same problem and did find a resolution. After trying numerous suggestions and trying to recreate missing tables, it just went from one problem to another, without ever getting to a satisfactory solution. Unfortunately, the best solution turned out to be the most drastic.

The problem you have is that one or more tables that should have been created with the mySQL/phpmyadmin installation didn't get installed. The mySQL/phpmyadmin installation is essentially incomplete.

You have two possible solutions. One is to completely remove and reinstall mySQL on the appliance. I wish I could point you at some good instructions, but I can't.

The other alternative, and the one that I ended up using was to completely uninstall the appliance and vmware, and reinstall from the start. Before you do this, make copies of all of your work and store them somewhere else on your computer. (One way to do this is to simply zip the entire Dropbox directory on the appliance and move it out of the appliance to somewhere else on your computer.) Be very thorough in the uninstall and follow the reinstallation instructions to the letter.

This process is always a pain and can present problems, so be careful, take notes on everything you do and the results it produces. Also, make sure that you have downloaded the installation software for vmware (or whatever you are using) and the appliance before you start.

This may get you squared away, or you may end up right back where you started, but it's my best bet solution. Others may have a better solution, but it's your call. Good luck.

If this answers your question, please click the check mark to accept this and remove the question from the unanswered pool. Let's keep up on forum maintenance. ;-)

| improve this answer | |
0

I had the same problem too but managed to get away without reinstalling the appliance. But if the following doesn't work as well I would suggest you follow @CliffB 's suggestion.

Try the following and let me know:

  1. In shell execute the following

    locate create_tables.sql
    

    If I'm correct it should output:

    /usr/share/doc/phpmyadmin/examples/create_tables.sql.gz
    

    If not, substitute the path on the following commands with the one you got.

  2. Execute

    sudo gzip -d /usr/share/doc/phpmyadmin/examples/create_tables.sql.gz
    
  3. Then execute

    ls /usr/share/doc/phpmyadmin/examples/
    

    and make sure there is a file named create_tables.sql on the output.

  4. In Chrome, go to http://pset7/phpmyadmin.

  5. Go to the Import tab at the top

    enter image description here

  6. Click Choose File, then click the pencil at the top-left corner and paste the path to the file, /usr/share/doc/phpmyadmin/examples/create_tables.sql.

  7. Then at the bottom click Go.

This should probably recreate the phpmyadmin table that you are missing. If not, I would suggest you go nuclear and re-import the appliance, or keep searching the web until you find a solution.


If this answers your question please accept it by clicking the gray check-mark to the left, so that it becomes green. You can also vote it up by pressing the up arrow above the check-mark. And don't forget to keep coding!

| improve this answer | |
0

I worked it out after installing directly the 29-release version of the appliance, I had the 26-release and I had to update it, but after installing directly the latest one, everything worked like magic.

| improve this answer | |
  • Where could you install the 29-release version of the appliance directly? – Andros Wong Sep 13 '15 at 15:44
  • The appliance manual is updated so you can download the 2014 version. – Amr Magdy Abdelhamid Sharaf Sep 15 '15 at 20:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .