0

The mouse has been difficult within the cs50 Appliance. Often, the mouse will not really click on something and move to a different location on the screen. How am I able to "re-set" this and be able to click and move things around within the computer? I restarted the computer for a total of three times and the mouse sometimes works now... lots of patience!

0

By difficult do you mean slow? This may happen due to the amount of memory allocated to the appliance slowing it down and making it looks like the mouse is the problem. To change the memory allocation just follow those steps (I'm assuming you're using VMware Player to emulate the appliance, but I believe the configurations are similar on other virtualization softwares as well):

  1. Turn off the appliance, and in the VM library selects the CS50 appliance.

  2. Then select on the tabs Player > Manage > Virtual Machine Settings (Ctrl + D)

  3. Now, on the Hardware Tab, select the Memory.

  4. Here's the fork in the road. Now, you have to check the amount of memory you have on your computer. Assuming you have 4GB, allocate 1GB to the appliance, since it doesn't need that much RAM to run smoothly.

  5. Click OK and turn the appliance on. Check if the mouse is softer now.

Source: VMware Player Documentation


Of course this can also be a problem with the mouse sensibility. To change that, just follow this:

  1. Click the icon at the very right of the menu bar and select System Settings.
  2. Open Mouse & Touchpad.
  3. Adjust the Pointer Speed slider until the pointer motion is comfortable for you.

Source - Ubuntu Documentation

Or you can use this hacker version on the forums:

How to Change Mouse Speed/Sensibility


If this answer helped you, give it a go on the check mark!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .