I tried accessing the site - https://cs50.io

Upon entering my edX credentials I'm able to see the IDE, but receive the error -

Failed to write to 'project.settings'. Access denied acccessing this file or folder.

I'm also unable to create any additional files in the workspace. Has anyone outside of Harvard/Yale been able to use https://cs50.io?

2 Answers 2


I had the same problem. I solved the "failed to write" error by issuing this command in the terminal in the lower part of the window:

sudo chown ubuntu ./.c9

After that, i did refresh the page and click in the gear in the left side navigation menu. I checked all the "show" options.

I can now create directories ~/workspace/.c9/ and files inside any directory that i create there.

I have not tested if it compiles or runs anything, i'm still using the appliance.

  • Great! I have the same problem with ide50, no idea where it is. Thanks for accepting the answer! Oct 29, 2015 at 12:35
  • That worked! It gave me write access to the .c9 folder, which is available under ide50/.c9 in the 'File System' column, and ~/workspace/.c9 in the 'Favorites' column. Interestingly, creating a folder under ide50 doesn't seem to work; and I'm not seeing that folder listed anywhere under ~/ GDB debugger doesn't seem to function though; clicking debug isn't yielding any information in the debug column - dl.dropboxusercontent.com/u/1308556/Videos/GDB.mp4 Oct 29, 2015 at 12:48

I also emailed Dan A. @ CS50 - apparently Cloud9 was having issues that particular evening with enviroment provisioning. I used the following steps to create a new workspace -

  1. Visit: https://cs50.io/dashboard.html
  2. Click on the name of your workspace, "ide50", which will bring up properties for that workspace.
  3. Click the gear icon, and select "Delete this workspace" in the danger zone and confirm deletion.
  4. Log out with the button up top of the page
  5. Log back in to cs50.io, where it should then create a brand-new workspace.

The new workspace was generated, and I am able to create files/directories within any folder, including under ide50.

  • Great, i followed your steps and it works now, thank you! Oct 30, 2015 at 8:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .