For some reason I can no longer boot the latest image of the appliance in VMware player. When I boot up the CS50 appliance it suddenly stops and throws me an error:

kernel panic-not syncing: VFS: unable to mount root fs on unknown block(0,0)

I can boot up if I select the oldest image in grub, once there if I run df I see that the image is only occupying 33% of the available memory. I suppose that later images have saturated available space and won't permit the boot of the last image.

I'm currently running on: Linux appliance 3.13.0-65-generic #106-Ubuntu

When I try to run update50, sudo apt-get update or dpkg --get-selections | grep linux-image-, to see which images are installed It all comes back to the same error:

dpkg-query: error: parsing file 'var/lib/dpkg/status' near line 29599 package 'liblockfile1'

I've tried all I can think of and have searched through several threads to no avail. Any help will be greatly appreciated.

kind regards, Mauricio


If you saved all your work in Dropbox, just re-import the appliance if anything goes wrong.

  • tried everything else I could think of and nothing worked. Re-importing and updating worked like a charm. Nov 5 '15 at 14:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .