0

Since the day before, the cs50 appliance was running perfectly in VMware Player installed on my Windows 7 machine. But suddenly the appliance has started working differently. Here are the problems:

  1. It opens with invisible mouse pointer, after logging in. I used to see the mouse pointer on opening and had worked in the appliance and even submitted pset1 in it!

  2. Somehow I manage to re-login after logging out and strangely, the mouse pointer comes back!

  3. After this exercise of login and relogin, another thing that happens is that my Chrome window neither maximizes nor minimizes even after clicking it on its icons (i.e 0 and - buttons).

  4. Until now gedit showed the title bar with the directory (e.g. ~dropbox/pset1) but now the title bar is invisible.

  5. Many times the appliance hangs and doesn't accept mouse or keyboard input.

6.The taskbar (i.e., the bar on which menu50 is seen) doesn't show the name of opened windows, where previously it did.

  1. Therefore, due to this, the multiple opened windows don't minimize to task bar and stay open.

Why has this happened suddenly? The only thing I remember is that it all began after I logged out and shut down appliance yesterday and opened the appliance today. I ran update50 but still no change.

1
  • That's really weird, but have you considered trying another hypervisor (e.g., VirtualBox)? – Kareem Jul 2 '14 at 9:28
0

This sounds like a hardware + software problem

I'm saying this because VMWare has been well known to not working with low on hardware machines, as well as on Windows Vista and below.

Though the best method to solve will be to buy a new machine with great hardware specs(better than your present one) or to update your windows version, or install a new OS like Ubuntu or any other Linux flavor but that's really not viable for just a course.

Other methods to solve this problem include(though it's possible they don't help):

  • Recreate a new VMWare machine for the CS50 Appliance and delete the present one.
  • Try installing VMWare WorkStation or VirtualBox or maybe even reinstalling the VMWare player!
  • Create a partition in your hard drive to install a new OS like Linux etc.
  • Consider upgrading windows
2
  • Thanks. I opted for repair option in VMware player and reset the path of CS50 appiance and all seems to work well. – user1231 Jul 27 '14 at 6:25
  • If you found my answer useful, be sure to upvote and accept it, @codeworm – Nib Jul 27 '14 at 6:36

You must log in to answer this question.