0

I tried to do hello.c and when I used the bottom black panel, after I typed make hello, I got "make: ***No rule to make target 'hello'. Stop.

Could it be because I don't have a Dropbox account?

And on the next line after the prompt, I got bash: ./hello: No such file or directory

What is the problem? Thanks!

  • Thanks for your help, but I already fixed it. I just had to reload it! Thanks. – sophiemath Dec 28 '15 at 18:52
1

Are you working in the online IDE or in one of the downloaded environments like VMware? If you are working in VMware, the license expires at the end of the year, in a few days. It also raises another question. Are you signed up for the class that starts at the beginning of the year, or the one that ends Dec 31, 2015? There's simply not enough time to start the 2015 class, so if you're just starting, you need to make sure you are in the 2016 version of the class.

Having said all that, the error you have is usually caused because you are not in the same directory as hello.c when you issued the make hello command. Also, be sure not to add the .c. to the end of the command as it will error out too.

If this answers your question, please click on the check mark to accept. Let's keep up on forum maintenance. ;-)

| improve this answer | |
  • Well when I downloaded the Virtual thingy, I thought I had version below 10.8 but I actually have 10.10. Would that make a difference? – sophiemath Dec 28 '15 at 18:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .