I have installed VMware Player on my Windows 7 machine and when trying to run the CS50 appliance 19 I get the following error:

VMware Player cannot open one of the virtual disks needed by this VM because it is larger than the maximum file size supported by the host file system. Some remote file systems do not support files larger than 2 GB, even though the file system on the server might.

The file is too large

Cannot open the disk '\ULVMCTMFIL107\DESKTOP107B\jbenitez\Documents\Virtual Machines\appliance50-19-vmware\appliance50-19-vmware-disk1.vmdk' or one of the snapshot disks it depends on.

Module DiskEarly power on failed.

Failed to start the virtual machine.

Can someone help?

  • Have you tried to decrease the size of the virtual hard disk?
    – kzidane
    Commented Jul 6, 2014 at 22:16
  • Can you do that with VMWare Player? How?
    – user1711
    Commented Jul 7, 2014 at 9:05
  • I'm not currently using VMWare Player, but the steps won't differ that much from that: Right click on the appliance in VMWare Player > choose settings > storage. You'll find your virtual hard disks there. If you're not able to shrink its size, you may backup your data to Dropbox, remove it and create a new one with a smaller size!
    – kzidane
    Commented Jul 7, 2014 at 10:39
  • thanks for your answer Kareem. I have tried to shrink the virtual hard disk with VMWare Player and it does not work. I have finally installed VM Virtual Box and the appliance works just fine. So I will use it instead of VMWare's. Regards.
    – user1711
    Commented Jul 7, 2014 at 12:46

2 Answers 2


CS50 appliance asked to be download was of size around 1 GB. Make sure that you have a correct copy of it. Check if size is around 1 GB or not.

Try to strictly follow the instruction on this page one by one and any avoid mistake


If you still think that the problem is not resolved than try to switch to VM Virtual box (link)


Even I faced such problem back when I used to do work on win 7. So I switched on to VM Virtual Box. However I'm not facing it right now in win 8.

  • thanks for your answer Prateek. CS50 appliance was indeed around 1GB, but when importing into VMWare Player it then moved into a 4GB one. My next move was to consider VM Virtual box as you suggest.thanks. Javier
    – user1711
    Commented Jul 7, 2014 at 9:07

This is an old question but the error is still current. I encountered the same error on Vmware Workstation, on Windows 10, and when I decided to use Virtualbox I got a different error, so I had to find a definite solution.

Searching the net lead me to a solution for the Virtualbox error which also solved the issue with VM Workstation.

Open cs50-appliance.ovf file - this is a XML file which is editable with any text editor. And do a search for 4 and change this to 3.

Now I can use the appliance on either (I prefer Vmware Workstation). Hope it helps someone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .