My computer does not have a HAV capable processor. Is there a workaround to allow VirtualBox to access the Internet?

Running on Ubuntu 14.04 so other possibility is to run CS50 projects directly, but having some problems with Makefile, library paths etc. to use the -lcs50 flag. Is there anywhere I could find this library instead of in the appliance package?

I tried the simplest options:

CFLAGS= -Wall -lcs50 -ggdb3

but it seems not to link properly.

  • @Kareem Do not edit questions to ask a different question than they are asking. Duplicate questions are questions that ask the same thing, not questions that might have the same solution. And even if this was a duplicate, it's useful for questions marked as duplicates to have different titles, so there are many different paths to the solution.
    – Air
    Jul 18 '14 at 15:54
  • @AirThomas sorry, but I don't see the point! How's that different? I though he's trying to compile and run C programs on his Ubuntu. He tried something, but it didn't work! I already marked this as a duplicate by the way! Sorry again if I'm mistaken!
    – kzidane
    Jul 18 '14 at 21:22

I used VirtualBox under linux Ubuntu 14.04 without hardware virtualization, and switched to HAV only some days after I started the course. You should be able to access Internet without HAV.

On this link you'll find a way to run CS50 library from your Linux distro.

  • Thanks. I've installed the library but think there is still a problem with the path. When using a project with #include <cs50.h> (sigma-1 as part of the course), I get 'undefined reference to GetInt' I think I'll have a similar problem when using gevent.h etc. Jul 18 '14 at 10:43
  • 1
    @StephenMatthews don't forget to link the cs50 library when compiling with the -l flag!
    – kzidane
    Jul 18 '14 at 11:12

Not the answer you're looking for? Browse other questions tagged .