I have implemented search.php and when I test the URL's given in the specs, I am able to see the pretty-printed JSON format I am supposed to see. However, whenever I type into my text box, I don't get any suggestions(not even the TODO's which I supposedly should be seeing) nor does my inputting a zip code move the map anywhere. I looked for others who have had this problem, and many people said to clear the cache using ctrl-f5. I tried this and it also did not fix my problem. Can anyone help me pinpoint what might be causing the text box to not at least display the TODO's? I am pretty positive I did not touch any of the code outside of search.php import and config.


1 Answer 1


Fixed it. I had an echo statement for debugging purposes in search.php that I put into place when I was trying to parse the search terms and didnt realize that that was messing with the functionality. Once I removed it the text box is back to normal.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .