3

My CS50IDE workspace was fine this morning, but it is not having issues. In my upper right nav I am now missing the link to my localhost (i.e. https://ide50-myusername.cs50.io), as well as the info icon that provides my mysql username and password.

Additionally, it appears my apache50 hosting is not working either. For a while, no matter where I ran apache50, https://ide50-myusername.cs50.io was stuck on a page I was hosting this morning.

I then tried the "Restart Workspace" option in the CS50 IDE menu, and it seems to have made things worse :/

After that step, I lost some of the display features that have always been there in CS50 (before it would say my username in bright green at the command line, now it says "/home/ubuntu" -- also, I am now getting forbidden errors anytime I fire up apache and try to host anything)

3

There is definitely a problem with permissions for apache50 in version 59 of ide50. Hopefully, the CS50 folks will fix this in the next version. Meanwhile, the apache50 log files are accessible at /home/ubuntu/lib/apache2/log/ and you may get a better idea of what is causing this error by restarting the server and watching the error log file via tail -f ~/lib/apache2/log/error.log while trying to load a URL that gives you a 403 error.

Update: I gave a more complete answer here:

https://cs50.stackexchange.com/a/19388/12172

| improve this answer | |
1

I attended a CS50 workshop this summer and can speak to a couple of these items:

  • The upper, right-hand corner display is now simplified. One quasi-bug was that when your window was not maximized, that information wasn't displayed, requiring you to make it bigger in order to see what you need. There is less in the corner, and as a result, you should always be able to see it.
  • It is intentional that your username is no longer displayed in the terminal. I, too, thought something was wrong until I got confirmation that that is the intended display moving forward.
  • As for apache50, I can only suggest typing apache50 stop (and killall -9 server if server.c was running) before trying again to restart with apache50 start [root].
  • Last (but maybe most important of them all): run update50. I just did while typing this reply, and I went from version 57 to version 59. You can find the requisite links to phpMyAdmin and your Web Server under the CS50 IDE menu (see picture below). (Note: I cannot seem to find the password for logging in to phpMyAdmin, so I need to do some digging to find that in the new version.)

CS50 IDE Menu

| improve this answer | |
  • Thanks for the input here - I appreciate the heads up on these items. There is definitely something wrong with Apache50 - no matter how many times I try to stop/restart/double check file permissions, it is giving me a 403 (my server from pset6 is working however). I've run update50 a couple times and still no luck. One thing you mentioned - looking for username/pass - you can run 'username50' or 'password50' at the command line and hit return, and it will give you those values. I found this in the readme. My mysql50 isn't working though, so not doing me any good, but they're at least there! – David M Jul 23 '16 at 8:01
  • 1
    Thanks for the tip re: username50 and password50. As for the 403 error, I've been getting that non-stop as well. Must be a bug in the update that needs fixing. – Peter Jul 25 '16 at 0:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .