1

I have an old HP dc7100, 3.2Ghx ubuntu 12.04 box i'm trying to do cs50 on. Windows 8.1 was a lost cause.

I'm getting this error message when I start the appliance:

Could not start the machine CS50 Appliance 19_1 because the following physical network interfaces were not found:

vboxnet0 (adapter 2), en0: Wi-Fi (AirPort) (adapter 3)

You can either change the machine's network settings or stop the machine.

A host-only adaptor shows in the network settings of virtualbox, but there's no names for it. No name for adaptor 3 either.

I'm new to linux, and I'm really stuck! Help

  • Same problem with VMware 11.1.0 build-2496824-Win with appliance50-2014-vmware VirtualBox 4.3.26-98988-Win with appliance50-2014-vbox i had the same problem, click on the "adapter 3" tab and uncheck the "Enable Network Adapter" box, let it boot but problem still exists Appliance works and loads. Chrome also works fine for internet browsing. But other apps like dropbox, Team Viewer, etc cannot connect to internet. Error: Dropbox during deamon download: trouble connecting to dropbox servers maybe your internet connection is down, or you need to set your http_proxy environment var – msa May 6 '15 at 0:08
1

Open up VirtualBox, single-click on the appliance and then click on "settings"

enter image description here

From the window that appears choose "Network", click on the "adapter 3" tab and uncheck the "Enable Network Adapter" box

enter image description here

Click "OK" and try starting up the appliance again.

| improve this answer | |
  • Are you sure this action doesn't affect internet connection? – JIT Develop Jul 25 '14 at 5:07
  • It wont effect the internet connection for anything outside of the VM machine. Enabling a network adapter will just add that interface to the CS50 appliance. – andy Jul 25 '14 at 7:26
  • @HasanSiddiqov don't worry! :) – Kareem Jul 25 '14 at 9:54
  • OK, but the thing is that i couldn't manage to make my internet working on both virtual machine and vm ware with the appliance. – JIT Develop Jul 25 '14 at 11:25
  • @HasanSiddiqov so you're still getting the same error message? – Kareem Jul 25 '14 at 11:50
0

i had the same problem,

click on the "adapter 3" tab and uncheck the "Enable Network Adapter" box

above solved the issue. thanks.

| improve this answer | |
  • Hi, welcome to Stack Exchange. If you are not providing a solution to the problem you should use the "comment" link below another post instead of submitting an answer. – Air Sep 12 '14 at 15:14
0

I had the same problem. After trying just about everything, I clicked on adapter 3 and chose not connected. It then worked as normal

| improve this answer | |
0

Now you can move on from using the VM and start using the new cloud based editor that they are going to use from next year instead of the appliance. Check it out here.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .