8

I'm presently working on the pset3 sort and search functions and I've found that the debugger button is missing from the menu bar, the viewer is still on the right, but my ability to place breakpoints is gone. Any body know how to correct the issue?

Screenshot of the IDE

  • Which browser are you using? For me it worked when I opened in another browser or refresh the browser cashe by ctrl + F5. – Wafeeq Jul 25 '16 at 11:17
  • I've got the same issue on Chrome, IE11 and Edge. Really odd, it had been working fine, but all gone now. – Mike McClory Jul 25 '16 at 11:44
  • I have also the same issue today again. I guess Server has Problem. I even cannot got to community from help. – Wafeeq Jul 25 '16 at 12:28
  • I have the same probable too. (in safari) – Iris Frenzy Jul 25 '16 at 16:08
  • I have the same problem too in Chrome and Firefox. It used to be there but now it's gone! – Leanne Aug 4 '16 at 14:40
4

EDIT September '16 The latest version of the IDE (69-ish) has a new utility called debug50.

I can't find a way to get the button back, but you can run the GUI debugger this way:

In View uncheck Less Comfortable. That will give more options in menu bar, specifically a Run tab and the green "> Run" button. When I tried the green Run, it did in fact invoke the debugger. You may need to experiment with "Run Configurations" (also in the Run dropdown), or the options in the "Run" window:

enter image description here

| improve this answer | |
  • This worked for me! – Iris Frenzy Jul 25 '16 at 16:17
  • Thanks, I can get to the same point but I can see how to insert breakpoints to be able to diagnose the issues that I have. – Mike McClory Jul 25 '16 at 16:33
  • In the source code tab/window click to the left of the line number, should place a red dot, which is the breakpoint. – DinoCoderSaurus Jul 25 '16 at 16:51
  • None of the earlier solutions worked for me but debug50 did work. – Hai Shang Oct 24 '16 at 2:50
6

I've just found that if you right click on the tab for the program, the menu list includes an option 'Run this program', this opens a new terminal and runs the program using the debugger.

| improve this answer | |
  • The other solution didn't work for me, but this one did, thanks. – roncook Sep 1 '16 at 18:32
  • That's so weird. I just noticed i don't even have a Run-menutab anymore. I've always been running with 'less comfortable'-view ticked off. Anyway, was able to access debugger by right-clicking on the file-tab. Thanks @Mike McClory – Mike224 Sep 2 '16 at 12:14
  • I was able to get the Run bar to come up at the bottom, but when I click on runner there's no option for C GDB Debugging – tamj0rd2 Sep 18 '16 at 9:17
0

It also looks like you can use F5 to access the debugger from less comfortable view

| improve this answer | |
  • Hi, not managed to get F5 to do anything. DinoCoderSaurus' workaround is working fine for me now that I've got used to using the debugger itself! – Mike McClory Aug 12 '16 at 8:59
0

I had this similar problem. Try to inspect the resource code of the webpage, look for "runbtn". You will see style = "display: none"; Delete the "display:none" and you'll see the green button. Hope it will help you. At least works for me.

| improve this answer | |
0

If you taking CS50x through eDX then please check out the "what's new" document. There they have mentioned about a new command called debug50. It has also been described there how to use it.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .