7

I've executed the chmod command as described in the instructions. My permissions is as in the image below:
Terminal

I've one problem though. I could not find the ⓘ icon toward CS50 IDE’s top-right corner. So, instead, I've figured my username and password by running on the command line username50 and password50, as specified in here.

4

Permissions have changed due to a recent update, but the problem specification has not been edited to reflect this.

PHP files and config.json now need to be set chmod 640, even though the problem specification says chmod 600. Also, all directories need a minimum of chmod 711, which your public directory has currently, but others like vendor and views do not.

Using chmod -R seems expedient, but it is a bad habit to get into. It may help to get the site to load, but it always leaves you with unneccessary security holes. Luckily, there is a better way.

I've consolidated my advice from several sources into this definitive guide on the CS50 Reddit.

Please read the guide! I hope it helps you.

If you get your permissions straightened out, let me know by clicking the green check mark. Otherwise this question will always remain marked as unanswered, and it will haunt the forum forever as a Zombie Question.

  • This worked like a charm on IDE v93. – Sean Nov 12 '16 at 17:50
  • @Sean: Glad it worked for you! Now, if only we knew whether or not it helped MatheusFacure ... – Matt Obert Nov 12 '16 at 23:00
0

I had the same problem.

I have used chmod on all the others directory like includes, vendors and views and give r+x rights on all files and directories and by the way I did it for pset7 directory but that one was probably not necessary. It is painful to go trough all the subdirectories and I would be happy to know a better way but at least now it is working...

  • I have tried to chmod vendor as its subdirectory’s and eventually I got an error when loading public for too many redirects. – Matheus Facure Jul 29 '16 at 14:26
  • I followed Roussetman's advice and it worked. It is not painful at all if you use 'chmod -R' on the pset7 folder, R stands for recursive. However, the pset7 instructions specify that we should not make some of the folders in there readable by others... but I couldn't make it work otherwise. – Andres Suarez Aug 29 '16 at 16:22
0

I have the same problem too, but after i chmod 775 to folder pset7/ . now it work fine for me.

  • Worked partially. ide50-matheusfacure01.cs50.io is now visible, but it subdirectory ide50-matheusfacure01.cs50.io/public is not. The error was as follows: Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0 and Fatal error: Unknown: Failed opening required '/home/ubuntu/workspace/pset7/public/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0 – Matheus Facure Jul 29 '16 at 14:10
  • something has gone wrong and cant figure it out . first i couldn't get the apache to start then i found this on web "echo > ~/lib/apache2/log/error.log" after that the apache worked but got an 403 error when loading the page then chmod 775 the pset7 directory now again stuck ."Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0" – Thisal Jul 30 '16 at 14:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .