2

I think something is incorrect with my permissions when I'm trying to set up my pset7 materials per the spec. I've followed the spec exactly. I used username50 and password50 to put my username and password in config.json. When I tried to get to the CS50 finance page through https://ide50-username.cs50.io/ it gave me a page that said "Not authorized to access this private project." I tried using chmod -R 755 pset7, per this post, to free up permissions, but that had no effect.

I've also tried

~/workspace/pset7 $ find ~/workspace/pset7/ -type d |xargs chmod 755
~/workspace/pset7 $ find ~/workspace/pset7/ -name *.php |xargs chmod 640
~/workspace/pset7 $ find ~/workspace/pset7/ -name config.json |xargs chmod 640

With no difference.

Please help! I'm trying to finish this problem set as soon as possible before I move in 24 hours.

0

If you are "not authorized to access this private project" the problem is most likely unrelated to file permissions on the server. Rather, you might need to be logged in to ide.cs50.io with your edX credentials before you can view the private project. Are you using the same browser to view the site as you are using to edit the site in CS50 IDE? Are you in Private or Incognito mode?

Another way to view the site would be to go into your Cloud 9 account settings and change your project setting from private to public ... but only if you are certain that is what you want to do.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .