After following the tutorial my gEdit window does not look the same as what the instructor is using in the video. His version is allowing him to view a Terminal window. Mine does not have this option.

Can someone tell me how to access the Terminal window in gEdit or give me another program that I can use? I also have Notepad++.

I downloaded version 2.30.1 of gEdit.

  • I had the same problem...followed the instructions to install the appliance to the letter, and gedit was broken (error every time I tried to use). So I tried apt-get install gedit, and that got it working; however, no terminal window. I found this solution: Use: sudo apt-get purge gedit* to uninstall everything related to gedit. Then install using sudo apt-get install gedit gedit-common gedit-plugins from LuisDeSousa on askubuntu.com Still no luck though, no terminal window on the bottom. Commented Feb 3, 2015 at 21:47
  • What should I do for Windows 7? I have CodeBlocks as well as gEdit and jEdit.
    – user13380
    Commented Aug 15, 2016 at 16:49

2 Answers 2


The terminal in the bottom of the gedit window is termed as Embedded Terminal. To get it in gedit,

  1. Open gedit, click View, enable Bottom Panel.
  2. Now click Edit, go to Preferences, then Plugins.
  3. Enable Embedded Terminal.
  4. If you don't find that option, then try sudo apt-get install gedit-plugins in terminal, and repeat the process again.
  • When I go to "View" the "Bottom Pane" option is grayed out. I also do not have the "Embedded Terminal" option in "Plugins". When I input the command you gave me to install it. How do I get it to run? Commented Jul 31, 2014 at 14:23
  • Through terminal.
    – sinister
    Commented Jul 31, 2014 at 14:25
  • I used to have the terminal on gedit, but it seems it's disappeared. I'm having the same problem as Kellen since the option is grayed out, but the difference is that I do have the plugin and it is checked. Help? Commented Oct 11, 2014 at 21:45
  • P.S. - I did just update the appliance though. Could that have something to do with it? Commented Oct 11, 2014 at 21:46
  • This should help.
    – sinister
    Commented Oct 12, 2014 at 1:08

Kellen - if you are downloading GEdit to use in conjuction with taking the course, you would be better off following the instructions for downloading and setting up the virtual appliance. David & the CS50 staff have made some environment configurations that your personal setup may not be able to mirror completely, and that could cause trouble down the road for you and your ability to complete coursework. If you are simply trying to get GEdit installed for some other purpose, carry on!

  • Thank you this is what I needed. Commented Jul 31, 2014 at 15:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .