I'm at pset3 and this error has never happened to me and it's pretty strange to me.

When I 'make' the file in my IDE, I get no errors whatsoever and my program runs smoothly. However, when I upload my file to check50, I get this error:

Expecting an exit code of  0.   ... but received the following on standard error instead —  fifteen.c:20:10: fatal error: 'cs50.h' file not found
        ^1 error generated.

Does anyone have any reasoning behind this?


Hmmm, two consecutive questions with roughly the same issue.

After running check50 on almost every problem from pset1 to pset5, it only happened on a handful of programs. Also, it has stopped happening on some of them, and only appears to be on one or two still.

I'm thinking there was some kind of system update in progress. My suggestion is to wait a while and try again. If it is still happening in a few hours, leave a comment with an update. It will need to be reported and addressed by staff.

[UPDATE] It is definitely a software update of the cs50 libraries in progress and appears to have introduced a bug or two. The problem should now be resolved.

If the problem has resolved itself, please click on the check mark to accept and remove this from the unanswered question pool. Let's keep up on forum maintenance. ;-)

  • 1
    I'm sorry for the repetitive question, I honestly did not find any similar type of the question on google or on stackexchange. I might have missed it. Thanks, anyways! Now it works! :)
    – samidha
    Sep 3 '16 at 20:51
  • Not a problem. In fact, it was a good thing. Because two questions popped up within minutes, with totally different psets, word got back to the people updating the system while they were still working on it and they were notified of the problem, able to find the problem and fixed it! Good work!
    – Cliff B
    Sep 3 '16 at 21:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .