This is what my terminal looks like. When I type nothing comes up. Enter and ctrl C do nothing. I've tried restarting my pc, changing browser, and rebooting the workspace but nothing changes. This is stopping me from getting anywhere with the court so I'd like to fix it ASAP.


Can you start a new Terminal?

If so, just start a new one and close the tab on the frozen one.

  • Tried that, nothing.
    – DSmith
    Sep 15 '16 at 2:15
  • do you see any errors in the js console, I mean just try ctrl+shift+I or just open developer tools from the drop down menu on the right side of your chrome tab in windows.
    – sk.76
    Sep 5 '18 at 5:19

It is possible to reboot the virtual machine by clicking the "CPU-MEMORY-DISK" tab top-right corner, but I doubt that will help. You can also try creating another workspace within c9 at https://c9.io/ and see if your terminal works there -- which coming to think of it very likely won't work if my first solution did not.

  • Doesn't change anything.
    – DSmith
    Sep 15 '16 at 2:16
  • You can try pressing ctrl-q to unfreeze the terminal if it broke after pressing "ctrl-s". C9 support's official response is adding "?reset=1" to the end of your workspace URL, however this doesn't work for everyone, also keep in mind this resets your entire workspace.
    – kluvin
    Sep 15 '16 at 13:21
  • Tried that reset, nothing happened (it basically just refreshed the page).
    – DSmith
    Sep 15 '16 at 18:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .