0

Lately, a lot of other users have been having trouble with phpMyAdmin, and my advice has always been: "Use mysql50 shell instead."

That's still my best advice, but I thought I'd try to see whether I could figure out what's making phpMyAdmin "no worky".

After running update50to bring the IDE up to version 71, I closed all my IDE tabs and restarted my workspace. Then I selected CS50 IDE --> phpMyAdmin from the menu, and was greeted by the following alert:

You are about to log in to the site "ide50-user-name.cs50.io" with the username "user-name", but the website does not require authentication. This may be an attempt to trick you.

Is "ide50-user-name.cs50.io" the site you want to visit?

Has anyone else experienced this?

I used phpMyAdmin a little bit when I was working on pset7, and this never used to happen.

1

OK, so I figured out what to do:

Open a new Terminal tab in the IDE.

Verify that mysqld is running:

~/workspace/ $ mysql50 status
MySQL is not running.
~/workspace/ $ mysql50 start
 * Starting MySQL database server mysqld
   ...done.
 * Checking for tables which need an upgrade, are corrupt or were 
not closed cleanly.

Verify that apache2 is running:

~/workspace/ $ apache50 status
Apache is not running.
~/workspace/ $ apache50 start ~/workspace/pset7/public/
Setting Apache's document root to /home/ubuntu/workspace/pset7/public ...
 * Starting web server apache2
 * 
Apache started successfully!
Your site is now available at https://ide50-user-name.cs50.io

It does not matter what directory you use as the Apache2 root; all that matters is that the server daemon is running.

Now go back to the CS50 IDE --> phpMyAdmin item in the menu, and you should be able to get in to phpMyAdmin.

I'm not sure why these steps are now required, since they were never required before, but this seems to be a good workaround for people who want to continue using phpMyAdmin.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .