I'm working on pset7,

i tried apache50 stop,

and killall -9 server (says - server: no process found)

but when I open my web server page, it's running the dynamic webpage I build from the class ( CS50 - lectures, syllabus). I tried both command again and again, but it's still running. Can somebody help?

  • @GarveWorm: Not the same thing at all. This question pertains to pset7 and the apache2 server daemon binary, not to pset6 and the server binary compiled from server.c. See my answer below for clarification. If you are having a problem with the pset6 server binary, please open a new question. Oct 11 '16 at 14:47

The error message:

server: no process found

should be self-explanatory. You're trying to kill a process that is not running.

That's because the Apache2 server daemon process is not called server. It's called apache2.

The command you are using will only kill the server binary that you wrote in Problem Set 6.

The correct command to kill a zombie Apache2 process is:

sudo killall -9 apache2

Also (as @DinoCoderSaurus always reminds me) you may be viewing an old website from your browser's cache. Try using Ctrl+F5 to force the browser to bypass the cache and reload the page over the network.

If this answers your question, please mark it as answered by clicking the green check mark. Otherwise, it will become a Zombie Question and haunt the forum forever!

  • 1
    You are probably right, but I cannot confirm. To stop the apache2 server, I used root privilege, by executing $ sudo service apache2 stop ( Thanks to Kareem Zidane ). @matt , PS - I'm marking your answer. Oct 13 '16 at 12:53
  • I edited my answer to include sudo, which is necessary to kill the apache2 process since it is not owned by the ubuntu user. Kareem's method works too. Oct 13 '16 at 20:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .