0

For the final project I am reusing the staff provided framework for pset7 but I cant seem to get the permissions right and get the default page to load though I cant seem to find what am I doing wrong. Made a folder named project in workspace in ~/workspace/project i downloaded the framework for pset7 using wget http://cdn.cs50.net/2015/fall/psets/7/pset7/pset7.zip unzipped the folder and changed its name from pset7 to wall so as to not confuse myself with pset7. Than made these folders world executable as it was in the specs of pset7 with

chmod a+x ~/workspace/project/wall/public

then went to

~/workspace/project/wall/public

and executed

chmod a+x css fonts img js
chmod a+r css/* fonts/* img/* js/*

as we know the permissions of ide have changed and as per the guied here on stackexchange that I used for pset7 and pset8 I executed these commands

cd ~/workspace/project/wall
find . -type d | xargs chmod 711
find . -name *.php | xargs chmod 640
chmod 640 config.json
find . -name *.js | xargs chmod 644
chmod 644 public/css/*
chmod 644 public/img/*
chmod 644 public/fonts/*

after this when I run apache using apache50 start ~/workspace/project/wall/public I am expecting the cs50 finance deafult homepage to load but instead I am getting error 403, have spend the last 3 hours trying to figure out what am I doing wrong. plz HELP

2
  • 1
    make sure the new "wall" directory has 711 permissions as well. (And maybe "project" if that is a new directory) Oct 17 '16 at 14:49
  • Your 403 error may not be related to permissions. See the first few paragraphs here: checkupdown.com/status/E403.html
    – andy5995
    Oct 18 '16 at 4:35
1

giving "wall" and "project" directory 711 permissions solved the problem for me. Thanks

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .