1

I've tried using apache50 stop + changing the port and I can't get the webserver to run on my machine, instead I get the error:

~/workspace/pset6 $ ~cs50/pset6/server 8081 public Stopping server

~/workspace/pset6 $ ~cs50/pset6/server 8080 public Stopping server

~/workspace/pset6 $ ~cs50/pset6/server public

Using /home/ubuntu/workspace/pset6/public for server's root

Port 8080 already in use Stopping server

Instead it appears that my full workspace (not just pset6) is hosted on https://ide50-username.cs50.io/

This may have to do with the Cloud9 IDE update -- is there any way to fix?

3

Have you tried to kill the server process before trying those commands?

killall server

Also you can kill the apache process, if it's running:

sudo killall apache2
3
  • killall server did nothing. I mention I'd tried apache50 stop; it says its stopping the server but then doesn't do anything / let me run the code as suggested in the PSET
    – borker
    Oct 25 '16 at 20:08
  • You're right, I missed that part where you explain you tried the stop command. I'm sorry! You can also try to kill the apache process with sudo killall apache2 Oct 25 '16 at 20:15
  • 1
    Suggested edit - killall apache2 worked. thanks!
    – borker
    Oct 25 '16 at 20:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .