0

I am working on pset8. However, the map won't load (only the search box shows up). When I check the network on Chrome developer tool, I found that it shows 404 error for various css and js files, including scripts.js. However, when I checked the file permission, they are already -rwxr-xr-x . I have tried by using other web browers to open the url, but get the same issue; tried update50 and reboot. None of them helped. Any idea? Thank you so much in advance!

0

Sorry I did not answer this sooner. chmod 755 is overkill for JavaScript files (which do not need to be executable by user, group, or world). These files only require chmod 644. Try it yourself and see.

The complete, tried-and-true, set of minimum permissions necessary for the "Mashup" Problem Set is described in detail here.

I'm glad you got things working, but I can't be sure why you were having the problem in the first place (or whether chmod 755 was actually necessary to fix your problem) since your solution changed a lot more than just permissions.

1
  • Thanks for the answer and the link. Will read it more carefully after I finish pset8. Struggling with it! – rhabdomere Nov 2 '16 at 1:23
0

I deleted all my pset8 files, re-downloaded them and then set js/* files to 755. Finally the map was loaded.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .