0

:( encrypts "a" as "a" using "a" as keyword

\ expected output, but not "a"

:( encrypts "world, say hello!" as "xoqmd, rby gflkp!" using "baz" as keyword

\ expected output, but not "xoqmd, rby gflkp!"

:( encrypts "BaRFoo" as "CaQGon" using "BaZ" as keyword

\ expected output, but not "CaQGon"

:( encrypts "BARFOO" as "CAQGON" using "BAZ" as keyword

\ expected output, but not "CAQGON"

0

Let me get my crystal ball out. ;-)

I don't see a line feed following the output.

Seriously, one of the hidden early lessons is to write code exactly to the project spec. Any differences, extra or missing text, prompts, spaces, line feeds, anything, will cause a fail with check50.

If this answers your question, please click on the check mark to accept. Let's keep up on forum maintenance. ;-)

4
  • How do you "see" a line feed? I don't understand what you mean. Can you clarify further please? Thanks!
    – Kaplam
    Nov 20 '16 at 5:04
  • It means that there was supposed to be a line feed at the end of your output. There isn't. If there had been, it would have appeared, for example, as "CAQGON\n".
    – Cliff B
    Nov 20 '16 at 5:11
  • I had that initially ...and it still generated the same error...just showing "CAQGON\n". So I thought the \n was the problem, and removed it.
    – Kaplam
    Nov 20 '16 at 18:44
  • I added it the "'\n" back in...and then realized what the problem was before. Initially, it was " \n" and not "\n". The extra space before the \ caused the error and then I had mistaken the error as due to the presence of the \n. It works now when it is just \n. Thanks, Cliff B!
    – Kaplam
    Nov 20 '16 at 18:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .