0

I've been working on the scripts.js file in Mashup and when I tied to load the google map canvas all that I am seeing is a white background (see below) with just a text box.

enter image description here

Initially the map loaded okay and I've been able to use search and add labels to the map but now I cannot do anything until I'm able to get the map to reload again. I've tried looking for solutions to overcome this problem on this forum and on CS50 Reddit but without success. I've tried reloading the map with ctrl F5, clearing my cache and also changing the permissions for the scripts.js file but none of this has worked. Other people have suggested that changing the date and time in the appliance might be a solution but I have no idea of how to access this option in my IDE window running with cloud 9. Does anyone out there have any ideas as to how I can get around this problem because I am stuck at the moment? Any help would be much appreciated.

1
  • I'm having the same problem; at first the map loaded - now it starts to load and then the screen says to check my js console. The console shows no errors - everything returns 200. I've changed date/time, permissions, I re-downloaded the pset three times, my code works for search and articles. I've tried it on 3 different browsers (and on PC and Mac). I can't even get it to load the original unaltered files anymore. I've also rebooted and ran update50. I'm stuck. Any ideas? Thanks in advance. – teresahornsby Jul 29 '17 at 21:51
0

A simple missing curly brace {, parenthese ( etc in your code can cause exactly this. Or in excess.

If you can't find it, post your entire scripts.js so we can try to see if that's the problem.

Otherwise, if you happen to find on your own that excessive/lacking curly brace, parenthese, whatever... please accept this answer.

2
  • Yuri, Thanks for getting back to me and I'm sorry for the late reply. It turned out that I managed to get the map back after a day or two by swapping my scripts.js files in the public folder for an unaltered scripts.js file. I'm still not sure what caused the problem initially though? – Mark Edwards Dec 4 '16 at 9:28
  • If you're curious, you can try to delete one closing curly brace a (just one, so it doesn't have a match anymore) anywhere in your file and see if that reproduces the problem. – Yuri Laguardia Dec 4 '16 at 10:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .