0

When I tried running CS50's staff solution to pset6 with ~cs50/pset6/server public, I get Stopping server.

apache50 stop gave me "Apache is not running!"

It occurred to me to try apache50 restart, and I got the following:

* Restarting web server apache2
(13)Permission denied: AH00091: apache2: could not open error log file /home/ubuntu/lib/apache2/log/error.log.
AH00015: Unable to open logs
Action 'start' failed.
The Apache error log may have more information.
   ...fail!
 * The apache2 instance did not start within 20 seconds. Please read the log files to discover problems

Any ideas??

0
0

Try:

killall server

Then

sudo killall apache2

Then:

cd ~/workspace/pset6
~cs50/pset6/server public

If this solves your problem, please click the gray check mark on the left to accept this answer.

4
  • When I ran the 1st two commands, I got back "no process found" both times. But somehow, ~cs50/pset6/server public is now working. Was it perhaps because previously, I hadn't run make server? I didn't think that was necessary since I'm not trying to run my own version of server.c, but cs50's.
    – neugierige
    Dec 11 '16 at 20:15
  • No, the server inside ~cs50 folder is already "made". But remember those commands I've mentioned in case server gets somehow stuck again! Good luck Dec 11 '16 at 20:43
  • Ok, then that confirms that those commands did resolve my issue. Thanks!
    – neugierige
    Dec 11 '16 at 20:58
  • Actually, if you got back "no process found" for both commands, they didn't do anything useful. Your problem somehow solved itself on its own! But those commands may be useful later anyway if you get a similar issue in the future. Dec 11 '16 at 21:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .