1

I'm just starting Pset7 and I followed the spec's directions exactly (on how to use chmod on the ~/workspace/pset7/public directory and on the files and folders that are in it), but then when I tried to get into my site on the server after starting Apache and MySQL, I got a 403 Forbidden error.

I'm thinking part of the problem might be the fact that my site URL is now "https://dragonosman2-dragonosman2.cs50.io" for some reason instead of "https://ide50-dragonosman2.cs50.io". If that's not a problem, though, then I wonder what's going on?

I also noticed that the database server, mysql50, was already running when I tried the command "mysql50 start".

6
  • Yeah, that helped. Thanks. Since it seems like the chmod commands given in the Problem Set specs are outdated, could you point me to the newer ones that I need to use for the Problem Set? – Osman Zakir Dec 15 '16 at 13:39
  • The spec will likely not be updated, because the pset will change for CS50x in 2017. The "updates" are found on this forum or reddit. – DinoCoderSaurus Dec 15 '16 at 15:08
  • Should I wait to do it in 2017, then? Since when I went ahead in the spec, I saw that it says that the PHPMyAdmin page has a database called pset7 already, but I didn't see one there when I looked. – Osman Zakir Dec 16 '16 at 12:28
  • That's entirely up to you. The instructions detail how to create the database for pset7 in the Getting Started section. -oo- – DinoCoderSaurus Dec 16 '16 at 14:09
  • So you mean the "mysql50 start" command? – Osman Zakir Dec 16 '16 at 14:18

Browse other questions tagged .