0

I'm trying to run the version of GDB that has the nice user interface (NOT the command-line version of GDB) in the CS50 IDE. I have used this version in the past, but suddenly it's not working for me. To run GDB on a C file, I right-click anywhere within the file and select 'Run This File'. A new terminal window opens up, but instead of running the debugger on that file, it outputs the following text (using recover.c from pset 4 as an example):

bash: line 1: pset4/jpg/recover.c: No such file or directory


Process exited with code: 127

This used to work for me, but suddenly it is not working. The file and directory path definitely exist (this happens with any file I try). I also made sure to set a break point at the 'main' function. Perhaps it is worth noting that the command-line version of GDB still works. Any help is appreciated.

1

What does it say in the new terminal window after "Runner:"? I suspect it says "Shell Command" or "Auto". A ".c" file cannot run in the shell. Has it been a while since you tried this? There used to be a debugger option for Runner, but I don't see it anymore. Perhaps it was deprecated when debug50 was released. Make sure you are on the latest version of the IDE (94 at this writing). From a command line, run debug50 recover and the GUI debugger will open in the right pane. You should be good to go.

1
  • I did not know about the debug50 command, but that worked for me. Thanks! Also, you're right that it says 'Shell Command' in the terminal window after 'Runner:'. The last time that this method (i.e., right-clicking in the .c file and selecting 'Run This File') worked for me was maybe four weeks ago (early December 2016). But since the debug50 command works, I guess this isn't a concern anymore. – Dan Dec 29 '16 at 15:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .