0

When running sudo apt-get update I get the following message:

dpkg: error processing package appliance50 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 appliance50
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried several things related to "autoremove" "clean" and "fix broken packages" but nothing solved.

3
  • That message is generic. It just means that the dpkg instance called by apt-get failed for some reason. It doesn't explain why, how, or give hints how to solve it. As a diagnostic message, it is not useful. – MARS Jan 30 '17 at 21:24
  • When I executed update50 this morning I got this: E: Internal Error, No file name for appliance50:i386, I hope this is a less generic error. – Luis Felipe Feb 1 '17 at 11:50
  • 1
    It is not possible to upgrade appliance50 if using vmware or similar, there is no longer support, you must use the IDE if you want to finish the course – MARS Feb 1 '17 at 21:44

You must log in to answer this question.

Browse other questions tagged .