1

I am using CS50 Appliance in Virtualbox with Windows 8.1 as my Host Operating System. I use proxy to connect to the internet in Windows 8.1. I configured Proxy in Virtual Box Via :

  1. File -> Preferences -> Proxy
  2. Setting the Proxy and Port number.

But connect50 fails to show any positive results, neither there is any option in chrome to configure proxy as in windows.

In short :- How to set system proxy inside cs50 appliance ?

0

How to configure appliance for proxy server

If your own computer sits behind an HTTP proxy server, you might need to configure the appliance to route HTTP traffic through that proxy as well. Here’s how.

Open a terminal and execute the below:

sudo gedit /etc/profile.d/proxy.sh

Add the following line to that (otherwise empty) file, where example.com is

the address of your proxy server and 80 is its port number:

export http_proxy=http://example.com:80/

Select File > Quit, and click Save when prompted.

Execute

sudo chmod 644 /etc/profile.d/proxy.sh

in the terminal.

Restart the appliance.
3
  • I tried this thing already, still Google Chrome does not work, only wget and update50 works.
    – Mercury
    Aug 18 '14 at 2:39
  • Same problem with me. I managed to install dropbox through a proxyless connection and apply proxy settings soon after, so it works. However, there is no way to set system wide proxy. The suggested command line method doesn't work either. Any breakthrough yet?
    – user2277
    Aug 25 '14 at 13:24
  • Can anyone please tell how to store username and password required to authenticate the proxy server?
    – Anonymous
    Apr 4 '15 at 9:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .