0

Im unable to run make hello - I have read through the other troubleshoot but unable to find out what iam missing. Please can someone help me if I have entered something incorrectly. Error make: *** No rule to make target `hello'. Stop.

enter image description here

1

Based on the screenshot, I'd say you are in directory ~/workspace, not ~/workspace/pset1, where your hello.c lies. make will try to guess what you meant with make hello, but since there is no makefile, and it does not find anything named "hello.c" or similar, there is no standard rule it could apply.

Change the directory by typing

cd pset1

and then try again

make hello

[edit] As @mars pointed out in the comments, it's stdio.h, which stands for STanDard Input/Output (and there's no "u" in "standard")

  • Hi, I tried the above but now I get the below error clang -fsanitize=integer -fsanitize=undefined -ggdb3 -O0 -std=c11 -Wall -Werror -Wextra -Wno-sign-compare -Wshadow hello.c -lcrypt -lcs50 -lm -o hello hello.c:1:10: fatal error: 'studio.h' file not found #include <studio.h> ^ 1 error generated. make: *** [hello] Error 1 – Aipou Chang Feb 2 '17 at 13:18
  • 1
    The header file is <stdio. h> – MARS Feb 2 '17 at 13:31
  • Thanks Blauelf and Mars. it worked!! – Aipou Chang Feb 8 '17 at 10:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .