0

When I ran the command "pip3 install --user -r requirements.txt" to download the dependencies for Sentiments in Pset6, it give me these messages as a result:

Requirement already satisfied (use --upgrade to upgrade): Flask in /usr/local/lib/python3.4/dist-packages (from -r requirements.txt (line 1)) Downloading/unpacking nltk (from -r requirements.txt (line 2))
Downloading nltk-3.2.2.tar.gz (1.2MB): 1.2MB downloaded Running setup.py (path:/tmp/pip_build_ubuntu/nltk/setup.py) egg_info for package nltk

warning: no files found matching 'README.txt'
warning: no files found matching 'Makefile' under directory '*.txt'
warning: no previously-included files matching '*~' found anywhere in distribution Downloading/unpacking plotly (from -r requirements.txt

(line 3)) Downloading plotly-2.0.2.tar.gz (824kB): 824kB downloaded Running setup.py (path:/tmp/pip_build_ubuntu/plotly/setup.py) egg_info for package plotly Requirement already satisfied (use --upgrade to upgrade): termcolor in /usr/lib/python3/dist-packages (from -r requirements.txt (line 4)) Downloading/unpacking twython (from -r requirements.txt (line 5)) Downloading twython-3.4.0.tar.gz Running setup.py (path:/tmp/pip_build_ubuntu/twython/setup.py) egg_info for package twython Requirement already satisfied (use --upgrade to upgrade): six in /usr/lib/python3/dist-packages (from nltk->-r requirements.txt (line 2)) Downloading/unpacking decorator (from plotly->-r requirements.txt (line 3)) Downloading decorator-4.0.11-py2.py3-none-any.whl Downloading/unpacking nbformat>=4.2 (from plotly->-r requirements.txt (line 3)) Downloading nbformat-4.3.0-py2.py3-none-any.whl (154kB): 154kB downloaded Downloading/unpacking pytz (from plotly->-r requirements.txt (line 3)) Downloading pytz-2016.10-py2.py3-none-any.whl (483kB): 483kB downloaded Requirement already satisfied (use --upgrade to upgrade): requests in /usr/lib/python3/dist-packages (from plotly->-r requirements.txt (line 3)) Downloading/unpacking requests-oauthlib>=0.4.0 (from twython->-r requirements.txt (line 5)) Downloading requests_oauthlib-0.8.0-py2.py3-none-any.whl Downloading/unpacking jsonschema>=2.4,!=2.5.0 (from nbformat>=4.2->plotly->-r requirements.txt (line 3)) Downloading jsonschema-2.6.0-py2.py3-none-any.whl Downloading/unpacking jupyter-core (from nbformat>=4.2->plotly->-r requirements.txt (line 3)) Downloading jupyter_core-4.3.0-py2.py3-none-any.whl (76kB): 76kB downloaded Downloading/unpacking ipython-genutils (from nbformat>=4.2->plotly->-r requirements.txt (line 3)) Downloading ipython_genutils-0.1.0-py2.py3-none-any.whl Downloading/unpacking traitlets>=4.1 (from nbformat>=4.2->plotly->-r requirements.txt (line 3)) Downloading traitlets-4.3.2-py2.py3-none-any.whl (74kB): 74kB downloaded Downloading/unpacking oauthlib>=0.6.2 (from requests-oauthlib>=0.4.0->twython->-r requirements.txt (line 5))
Downloading oauthlib-2.0.1.tar.gz (122kB): 122kB downloaded Running setup.py (path:/tmp/pip_build_ubuntu/oauthlib/setup.py) egg_info for package oauthlib Installing collected packages: nltk, plotly, twython, decorator, nbformat, pytz, requests-oauthlib, jsonschema, jupyter-core, ipython-genutils, traitlets, oauthlib Running setup.py install for nltk warning: build_py: byte-compiling is disabled, skipping.

warning: install_lib: byte-compiling is disabled, skipping.


warning: no files found matching 'README.txt'
warning: no files found matching 'Makefile' under directory '*.txt'
warning: no previously-included files matching '*~' found anywhere in distribution   Running setup.py install for plotly
warning: build_py: byte-compiling is disabled, skipping.

warning: install_lib: byte-compiling is disabled, skipping.

   Running setup.py install for twython

warning: build_py: byte-compiling is disabled, skipping.

warning: install_lib: byte-compiling is disabled, skipping.
   Running setup.py install for oauthlib
warning: build_py: byte-compiling is disabled, skipping.

warning: install_lib: byte-compiling is disabled, skipping.

 Successfully installed nltk plotly twython decorator nbformat pytz requests-oauthlib jsonschema jupyter-core ipython-genutils

traitlets oauthlib Cleaning up...

What do I do to fix this?

  • Is there anything you need to fix, like are there any errors? I had warnings, too, but never experienced any problems. – Blauelf Feb 27 '17 at 17:31
  • Only warnings on my end, too. But I'm worried about the byte-compiling one in particular. How do I fix that one? – Osman Zakir Feb 27 '17 at 17:43
  • I assume the byte compiling is mostly a performance thing. – Blauelf Feb 27 '17 at 18:33
  • I signed up for a Dev. account on Twitter and even added my cellphone number to my Twitter profile, but I'm still getting an error on the "Create an application" page on Twitter that says, "You must add your mobile phone to your Twitter profile before creating an application. Please read support.twitter.com/articles/… for more information.". You know anything? – Osman Zakir Feb 27 '17 at 19:35
0

This is an option that is deliberately set by CS50's IDE setup, shown in the link below. So, it looks like this is the intended behavior and shouldn't cause problems.

https://github.com/cs50/ide50/blob/master/files/etc/profile.d/ide50.sh#L63

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .