0

I've completed the cs50x 2016 version last december and I'tried to see the mashup code working again in order to see code and reuse it and maybe modify it. I tried to run it as usual but it didn't worked. Maybe it's because the CS50 IDE doesn't work any more as expected for this problem set because the actual mashup pset works with python, and I did it with php. I

The message error that I got is:

Google Maps API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys

Thank you in advance! :)

3
  • My 2016 version of mashup works fine, no API keys required, as long as I start apache50 (apache50 start ./public from pset8 directory) and start mysql50 (mysql50 start). On version 98 of IDE. Perhaps edit the question and give more detail on the error you are encountering. – DinoCoderSaurus Mar 9 '17 at 17:23
  • Hello @DinoCoderSaurus I've changed the description and showed the warning that is displayed. I followed each step as always (apache50 start of public library and mysql50start) but It doesn't work. =S – Vale PorTi Mar 9 '17 at 21:05
  • @DinoCoderSaurus, Found the problem :), but still don't know why hehe. – Vale PorTi Mar 9 '17 at 21:43
0

I finally worked. Because my code didn't changed, it seemed an external problem so my first thought was the update50 IDE update but it wasn't. In fact, the problem was the way I was entering cloud9. I have done an "official" account of cloud9 from it's main page in order to create another workspace and that seems to be the problem, I don't know why but getting into my cloud9 account from edX, by clicking in the links in the pset8 and entering with the edX interface, make it work.

Maybe there's an opportunity of improvement or if you know why this happens, let me know, I will be glad to hear the answer :).

Thank you

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .