0

I have seen all answers mentioned earlier but I seem to still not navigate out of the problem.

More so because yesterday when I complied hello.c and water.c they worked fine. I even submitted the answers. This morning when I was attempting the Mario.c i kept getting this error.

Please find the screenshot attached with my dashboard so that you can help me with my problem.

Thank you! Sonicenter image description here

1

You are currently in the general directory called workspace. However, mario.c, water.c, and hello.c all exist in the pset1 directory. When you type make mario, make hello, and make water into the terminal, the computer tries to search for the files, but, since they don't exist in workspace, the computer can't find these files. Type cd pset1 into the terminal to go into the pset1 directory. Then, you'll be able to make all your files.

If you still have issues, comment below.

0

Check what directory you're in. The program is unable to compile because it cannot find the target source file.

The code is fine.

0

I am having the same problem when I run make addition it works fine. Now when i try to run population I get the same error I know it is me doing something wrong but I can't figure it out. I made a directory with mkdir it shows up when i check the gui folders with population in it can someone please help.

3
  • I am runnig linux pop-os – Oldnewbee Jan 7 at 19:14
  • 1
    Please make a new question with a screenshot of your terminal or more information. It sounds like you are trying to run the make command in the wrong directory, but that is all I can guess with the given information. – Robert S. Pratt Jan 7 at 19:21
  • 1
    This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Cliff B Feb 2 at 7:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .