I tried to install CS50 appliance by first installing the VMware Player, then downloading the 1.6GB CS50 appliance file as per instructions. But when I tried to import the CS50 appliance file through VMware player I got this error:

"The import failed because C:\Documents and Settings\Furrukh\My Documents\Downloads\appliance50-19-vmware.ova did not pass OVF specification conformance or virtual hardware compliance checks.

Click Retry to relax OVF specification and virtual hardware compliance checks and try the import again, or click Cancel to cancel the import. If you retry the import, you might not be able to use the virtual machine in VMware Player."

I have an old PC that runs at 3.1GHz with 512MB of RAM. Can my PC run the appliance?

3 Answers 3


As lethaljd said, you don't have enough memory. However, Virtualbox requires 512mb but it won't use all of it so you might get away with using it. Use this tutorial: https://manual.cs50.net/appliance/19/virtualbox/

  • I tried it but after installation, Virtualbox is not starting and not even giving any error Aug 21, 2014 at 18:39
  • If you cannot get another computer, then your best option is to dual boot a second, lighter OS (Lubuntu for example) and then download the CS50 library to start coding in it. Without the appliance you will face some more problems down the road but at least you can get started. If you are unsure about setting up what I just suggested, do some research and let me know too.
    – user103853
    Aug 21, 2014 at 18:47
  • sorry....a restart solved this issue.Now the virtualbox ran and tried importing the the appliance but after 80% got this error Failed to import appliance D:\appliance50-19-vmware.ova. Could not create the imported medium 'C:\Documents and Settings\Furrukh\VirtualBox VMs\vm\appliance50-19-0-vmware-disk1.vmdk'. VMDK: cannot write allocated data block in 'C:\Documents and Settings\Furrukh\VirtualBox VMs\vm/appliance50-19-0-vmware-disk1.vmdk' (VERR_DISK_FULL). Result Code: VBOX_E_FILE_ERROR (0x80BB0004) Component: Appliance Interface: IAppliance {3059cf9e-25c7-4f0b-9fa5-3c42e441670b} Aug 21, 2014 at 19:38
  • Check how much space you have left on your hard drive. You may need to remove unnecessary files, or copy some to another storage medium to have enough space to install the appliance.
    – user103853
    Aug 21, 2014 at 20:00
  • have got 6.24GB in C. How much space does it require? just occured to me that can FAT32 system be the reason for this? Aug 21, 2014 at 20:02

VMWare specs. state minimum required RAM is 1 GHz processor and 1 GB RAM. I don't think you have enough RAM.

  • is this just the ram issue or the hardware assisted virtualization issue too? Aug 21, 2014 at 15:31
  • likely just the RAM issue.
    – lethaljd
    Aug 21, 2014 at 18:25

Running a virtual OS with those specs is going to be challenging. If none of the other proposed virtualisation solutions work, your best bet might be install Fedora Linux directly on the box. See here for more info on running on a low memory environment.

You can then install the CS50 library as per the instructions here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .