1

I followed each step carefully and my directory path is:

jharvard@appliance (~/vhosts/localhost/public/pset8)

ls -l gives me:

drwx--x--x. 2 jharvard students 4096 Nov  8  2013 css
drwx--x--x. 2 jharvard students 4096 Nov  8  2013 fonts
drwx--x--x. 2 jharvard students 4096 Nov  8  2013 img
-rw-r--r--. 1 jharvard students 4311 Nov 10  2013 index.html
drwx--x--x. 2 jharvard students 4096 Nov 13  2013 js

So everything looks fine?

But when I entered the IP address of the virtual machine http://w.x.y.z/pset8 I received the error message "webpage is not available."

Why does that happen?

1

OK. Problem solve. Turned out to be I was using a VPN at my school and somehow it stopped my access to the webpage:)

0

The solution would be to configure the VMnet network adapters to use DHCP. I did it as follows:

  1. Click on the Start Menu search (bottom left corner)

  2. Type: "view network connections" find it on the list that appears and open it.

  3. Right click on "VMware Network Adapter VMnet1" and click on Properties. (You should be on the Networking tab in the new window that appears)

  4. Where it says "The connection uses the following items:" left click on Internet Protocol Version 4 and then left click on the Properties button

  5. In the new window you should be on the General tab. Click on the options that say: "Obtain an IP address Automatically" and "Obtain DNS server address automatically".

  6. Now click on OK then Close. You should still have your Network Connections window up.

  7. Repeat steps 3 to 6 but for "VMware Network Adapter VMnet8".

All done! Now make sure you restart your computer before opening the CS50 Appliance again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .