0

Hi I'm currently working on pset 8 and have noticed an error msg in the file helpers.py on the line "import urllib.parse". The error message states "no name 'parse' in module 'urllib'".

I haven't changed any code within the file and wasn't able to find any solutions on the net. Any help would be appreciated.

c9 terminal python --version shows Python 3.4.3.

edit: https://www.reddit.com/r/cs50/comments/6bwmvz/pset8_helperspy_urllib_has_no_parse_member/ seems to be having the same issue

2
  • The code downloaded with wget https://github.com/cs50/problems/archive/mashup.zip (today) does not have a from urllib import parse. It has import urllib.parse. May 31 '17 at 15:46
  • Yea it's "import urllib.parse" i must have made a mistake with my initiall question. Regardless, it's still showing the same error message in the c9 editor.
    – Stefan
    Jun 1 '17 at 4:31
0

Sounds like the linter is using python2. Verify that CS50 IDE -> Preferences -> Project Settings -> Python Support -> Python Version is set to Python3.

If you make changes in Preferences, you need to refresh the browser page so that they take effect.

1
  • Thanks! That worked.
    – Stefan
    Jun 2 '17 at 9:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .