0

When I try to update via update 50 i get this message.

pip can't proceed with requirement 'lxml>=3.0 (from WeasyPrint->render50==2.0.0)' due to a pre-existing build directory. location: /tmp/pip_build_root/lxml This is likely due to a previous installation that failed. pip is being responsible and not assuming it can delete this. Please delete it and try again.

Storing debug log for failure in /home/ubuntu/.pip/pip.log Something went wrong! The output has been logged in /home/ubuntu/lib/ide50.log

0

I was also having issues with update50 (a different error though). Try the following:

  1. Close and reopen all terminal windows, then run update50 again.
  2. Force refresh your page (Ctrl + F5) and attempt again.
  3. Close all cs50.io tabs and reopen cs50.io. Rerun update50.
  4. Close and fully shut down your browser (with Chrome, check system tray and task manager for lingering processes), then reopen browser and cs50.io.
  5. Try a different browser.
  6. Restart your computer.

If that doesn't work, close the tab and wait a few minutes. The CS50 staff seem to be aware of the issues and are apparently bug-squashing. Good luck!

EDIT: If the above doesn't work, also include some info about what you tried.

3
  • Sidenote: Apparently Harvard's CS50 staff are redoing the code for the new semester and some bugs are to be expected.
    – Coby Z
    Jul 14 '17 at 18:05
  • I tried all 6 methods and none seem to work. I can supply the log file if it makes it clearer whats going on.
    – noobcoder
    Jul 14 '17 at 21:43
  • @noobcoder Have you tried running it today? Are you still having issues? (Also supplying the log might help)
    – Coby Z
    Jul 15 '17 at 22:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .